Nettlesere som er støttet av Canvas?

Canvas er bygget ved bruk av webstandarder og kjører dermed på Windows, Mac, Linux, iOS, Android eller andre enheter med en moderne nettleser.

Støttede nettlesere

Canvas støtter den nåværende og den siste tidligere store versjonen av disse nettleserne:

  • Chrome 76 og 77
  • Firefox 68 og 69 (utvidede utgaver støttes ikke*)
  • Edge 44 (Kun Windows)
  • Respondus Lockdown nettleser (støtter de nyeste systemkravene)
  • Safari 12 og 13 (bare Macintosh)

Du bør alltid bruke den nyeste versjonen av din foretrukne nettleser. Nettleseren din vil varsle deg hvis det er en ny versjon tilgjengelig.

Nettleserfane støttes ikke

Noen støttede nettlesere kan fortsatt produsere et banner om nettleseren din ikke oppfyller minimumskravene for Canvas. Hvis du har oppgradert nettleseren din, men fremdeles ser advarselbanneret, kan du prøve å logge ut av Canvas og slette informasjonskapslene dine.

Enterprise-nettlesere med utvidede utgaver

Chrome og Firefox tilbyr utvidede utgaver for organisasjoner som behandler klientskrivebord. Chrome ESR kan holdes oppdatert med eksisterende fullversjon av Chrome, når som helst. Men Firefox ESR oppdateres bare hver syvende hovedversjon, som fører til at Firefox ESR overlapper med utdaterte versjoner. Firefox ESR nettside merker at ESR ikke støttes for hver nettapplikasjon på grunn av denne forsinkelsen i versjonutgivelsene. Institusjoner som bruker Firefox ESR bør vurdere å ta i bruk den siste utgivelsen for å sørge for den beste Canvas-brukeropplevelsen.

* For utvidede nettleserversjoner, gjelder fortsatt advarselsfanen og vises i Canvas for alle nettleserer under minimums versjonskravet.

Kjente nettleseratferder

Som alle Canvas-egenskaper, i strid med atferder relatert til nettlesere er prioritert av våre produksjonsteam, og noen atferder i tidligere versjoner er muligens ikke rettet opp i. Om en atferd finnes i den forrige versjonene og nettleseren som ikke eksisterer i nåværende versjon, er den beste løsningen å oppdatere til siste versjon av nettleseren.

Tilgjengelighet

Canvas er forpliktet til W3C internett-tilganginitiativ. For å lære mer om støttede skjermlesere og nettleser-kombinasjoner, se dokumentet Tilgang inne Canvas .

JavaScript

JavaScript må være aktivert for å kjøre Canvas.

Pluginmoduler for nettleser og utvidelser

Noen nettleser-pluginmoduler eller utvidelser kan komme i konflikt med Canvas og påvirke funksjonaliteten. Hvis du opplever atferd som ikke lar deg vise eller delta i Canvas-emner, kontrollerer at du har deaktivert alle utvidelser eller pluginmoduler som samhandler direkte med nettleseren.

For feilsøking kan du vurdere å logge inn i Canvas med et inkognito, som vil gi en nettleserøkt uten noen tidligere leselogg eller søkehistorikk tilknyttet informasjonskapsler eller andre faktorer som kan forstyrre nettleseren. Hvis du er i stand til å vise eller delta i Canvas med et inkognito eller privat nettleservindu er problemet du opplever sannsynligvis knyttet til nettleseren og ikke Canvas.

Personverninnstillinger for Nettleser

For å sørge for nettleserens sikkerhet, følg alle sikkerhetsretningslinjer for nettlesere etablert av institusjonen din, spesielt hvis du bruker Canvas på en datamaskin anskaffet av institusjonen selv.

Når du viser innhold vil Canvas bruke standardinnstillinger satt av en bestemt nettleser. Noen nettlesere kan noen ganger endre personverninnstillinger for å beskytte brukere mot mulig usikkert innhold. Usikkert innhold identifiseres med prefikset http:// i URL-en og kan medføre blandet innhold på Canvas-siden. Sikret innhold identifiseres med prefikset https:// i URL-en nettadressen. For en best mulig brukeropplevelse bør innhold være sikret for å unngå nettleser-konflikter.

  • Hvis du er en Canvas-administrator, kan usikkert innhold forårsakes av å drifte en usikker JS/CSS-fil utenfor Canvas. Hvis egne opplastinger støttes for kontoen din, kan du drifte filene dine i redigeringsverktøyet for tema, som vil løse alle nettleserkonflikter.
  • Hvis du er en Canvas-instruktør som legger til Canvas-leksjoner i emnet kan du forhindre nettleserproblemer med blandet innhold ved bruk av sikret Canvas Guides URL-er. 

Kjente nettleseratferder

Chrome og Firefox bruker HTML5 til å vise nettsideinnhold, og fremmer en raskere, mer sikker nettopplevelse. HTML5 støttes ikke i Microsoft og Safari-nettlesere, og innhold må fortsatt brukes via Flash. 

For best ytelser i Canvas, bør emneinnhold designeres til å støtte HTML5. Alt påvirket innhold i Microsoft og Safari-nettlesere kan fortsatt åpnes ved å manuelt tillate Flash-innhold i nettleseren.

I nettlesere som Safari vil usikkert innhold aldri vises i nettleseren.

Men i Chrome og Firefox har du muligheten til å vise usikkert innhold. Vær oppmerksom på mulige restriksjoner og vær varsom ved visning av usikkert innhold.

Følgende er kjente problemer i Chrome og Firefox som kan blokkere eller opprette blandet innhold innen Canvas.

Chrome Sikkerhet

Chrome Sikkerhet

Google Chrome bekrefter at nettsted-innholdet du viser overføres sikkert. Hvis du besøker en side i Canvas-emnet ditt som er knyttet til usikkert innhold vil Chrome vise et skjoldikon (shield icon)[1] i nettleser-adresselinjen.

Du kan overstyre sikkerhetsbegrensningen og vise innholdet uansett ved å klikke på skjold-ikonet og deretter på knappen Last usikre skript (Load unsafe script) [2].

Mediatillatelser for Chrome

Chrome har sin egen mediatillatelse i nettleseren. For å bruke datamaskinkameraet og mikrofon i enhver Canvas-funksjon må du godkjenne to tillatelser:

  1. Gi adgang til Canvas via Adobe Flash Player innstillinger (Adobe Flash Player Settings)[1]. Denne meldingen vises i midten av popup-vinduer for video og lyd eller midten av nettleseren hvis du åpner Samtaler.
  2. Gi tilgang til Canvas via Chromes innstillinger for mediatillatelser (Chrome’s Media Permission Settings) [2]. Denne meldingen vises rett under adressefeltet. Klikk på « tillat » (Allow).

Firefox-sikkerhet

Firefox-sikkerhet

Firefox bekrefter at nettsted-innholdet du viser overføres sikkert. Hvis du besøker en side i Canvas-emnet ditt som er knyttet til usikkert innhold vil Firefox vise en hengelås med et advarselsikon i nettleserens adressefelt (Browser address bar)[1].

Du kan velge å overstyre sikkerhetsbegrensningen og vise innholdet uansett ved å klikke låsen med advarselsikonet, klikke pilen for å utvide alternativer (expand your options)[2] og velge Deaktiver beskyttelse for nå -knappen (Disable Protection for now)[3].

Canvas på mobile enheter

Canvas-grensesnittet var optimalisert for skrivebord-skjermer, så bruk av små skjermer som telefoner gir ikke nødvendigvis en hyggelig opplevelse ved bruk av Canvas. For å få den beste brukeropplevelsen, last ned mobilapplikasjonene fra Canvas.

Siden Canvas bruker små elementer av Flash vil muligens ikke alle Canvas-funksjoner støttes av mobile enheter – spesielt av iOS. Canvas tilbyr imidlertid begrenset støtte for innkommende mobilnettlesere på nettbrett. For ekstra detaljer, referer til retningslinjene for begrenset støtte for mobilnettleser.

Mobile nettlesere

Besøk Apple store eller Play store for å laste ned mobile nettlesere. Følgende nettlesere er kompatible med mobile enheter:

iOS

  • Safari (standard nettleser med begrenset støtte for Canvas)
  • Chrome
  • Adobe Flash Player (støtter Flash)

Android

  • Chrome (standard nettleser med begrenset støtte for Canvas)*
  • Internet Explorer
  • Firefox

 

*Android standardnettleser varierer mellom mobilenheter.